Gem 1.3.2+ on Ubuntu 9.10 from scratch

So I was working on a new install of and it needed Gem 1.3.2 which doesn't come with the Ubuntu 9.10 in the apt-get packages.

I made sure that Ruby 1.8.7 was install on the system by entering this
ruby -v
If nothing showed up refer to my ruby post for installation instructions.

Ok, so I am going to download the installer to the linux machine and then install
cd rubygems-1.3.6
ruby setup.rb
Everything should have installed properly. Now look in the folder /usr/bin/ for gem1.8. Now most people might have already caught this but I didn't at first. you can't run "gem" from command line because it is actually gem1.8. I created a sym link to the gem1.8 with the below command.
cd /usr/bin
ln -s gem1.8 gem
That should do it. Log into the system as a regular user and then enter the below to check the gems version
gem -v


Popular posts from this blog

Console over SSH (ONTAP)

Brocade Zone Setup

OpenSolaris ZFS Setup